summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorFis Trivial <ybbs.daans@hotmail.com>2018-05-12 10:11:29 +0000
committerLudovic Courtès <ludo@gnu.org>2018-05-20 23:34:27 +0200
commit62813c10a926df99085b49fa8b753e09e45b33fd (patch)
tree6838abe81e23e969b02a4ed2c9a82782d3ae8a68 /gnu/packages/image.scm
parent1900fa792f1fa64f7a17a87a4414efd424d41d53 (diff)
downloadpatches-62813c10a926df99085b49fa8b753e09e45b33fd.tar
patches-62813c10a926df99085b49fa8b753e09e45b33fd.tar.gz
gnu: Add vigra-c.
* gnu/packages/image.scm (vigra-c): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index bbfd621a93..b88f6cf9de 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
+;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -843,6 +844,39 @@ multi-dimensional image processing.")
(license license:expat)
(home-page "https://ukoethe.github.io/vigra/")))
+(define-public vigra-c
+ (let* ((commit "a2ff675f42079e2623318d8ff8b4288dbe7a7f06")
+ (revision "0")
+ (version (git-version "0.0.0" revision commit)))
+ (package
+ (name "vigra-c")
+ (version version)
+ (home-page "https://github.com/BSeppke/vigra_c")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (sha256
+ (base32
+ "1f1phmfbbz3dsq9330rd6bjmdg29hxskxi9l17cyx1f4mdqpgdgl"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; No test target.
+ (native-inputs
+ `(("doxygen" ,doxygen)))
+ (inputs
+ `(("fftw" ,fftw)
+ ("fftwf" ,fftwf)
+ ("vigra" ,vigra)))
+ (synopsis "C interface to the VIGRA computer vision library")
+ (description
+ "This package provides a C interface to the VIGRA C++ computer vision
+library. It is designed primarily to ease the implementation of higher-level
+language bindings to VIGRA.")
+ (license license:expat))))
+
(define-public libwebp
(package
(name "libwebp")