summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-25 14:19:14 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-25 14:19:14 +0100
commit7c1ea9316a3fd4212c08f8c3767dbd654d5136c6 (patch)
tree52f8a91dc689df172c3c025935c6fb70017c2cdc /gnu/packages/image.scm
parentfa8e0a5387419ba1edd17722329cdb27b1371ccf (diff)
downloadpatches-7c1ea9316a3fd4212c08f8c3767dbd654d5136c6.tar
patches-7c1ea9316a3fd4212c08f8c3767dbd654d5136c6.tar.gz
gnu: cmake-minimal-bootstrap: Rename to cmake-bootstrap.
...and change the inheritance order while at it, to prepare for the next commit. * gnu/packages/cmake.scm (cmake-minimal): Rename to ... (cmake-bootstrap): ... this. [name]: Set to "cmake-bootstrap". [native-inputs]: Change from CURL to CURL-MINIMAL. (cmake-minimal-bootstrap): Remove variable. (cmake-minimal): New variable, inherits from CMAKE-BOOTSTRAP. * gnu/packages/image.scm (libjpeg-turbo)[arguments]: Change from CMAKE-MINIMAL-BOOTSTRAP to CMAKE-BOOTSTRAP.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 1b86f700e4..ebb30742a4 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1512,7 +1512,7 @@ is hereby granted."))))
'()
;; Use a special "bootstrap" CMake for the native build to work
;; around a circular dependency between CMake and this package.
- `(#:cmake ,cmake-minimal-bootstrap))))
+ `(#:cmake ,cmake-bootstrap))))
(home-page "https://libjpeg-turbo.org/")
(synopsis "SIMD-accelerated JPEG image handling library")
(description "libjpeg-turbo is a JPEG image codec that accelerates baseline