summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-11-25 10:22:25 -0500
committerLeo Famulari <leo@famulari.name>2017-11-25 10:23:38 -0500
commitef56fdc18d8dedd1a528350529dd038ec2e870b7 (patch)
tree1432cfe8500b1b0a3e652911fb4d4d2961d778c1 /gnu/packages/image.scm
parentd6adba786cf2ab1b26ff083928b64262281ff106 (diff)
downloadpatches-ef56fdc18d8dedd1a528350529dd038ec2e870b7.tar
patches-ef56fdc18d8dedd1a528350529dd038ec2e870b7.tar.gz
gnu: jbig2dec: Update to 0.14.
* gnu/packages/image.scm (jbi2dec): Update to 0.14. [source]: Remove obsolete patches. * gnu/packages/patches/jbig2dec-CVE-2016-9601.patch, gnu/packages/patches/jbig2dec-CVE-2017-7885.patch, gnu/packages/patches/jbig2dec-CVE-2017-7975.patch, gnu/packages/patches/jbig2dec-CVE-2017-7976.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. * gnu/packages/patches/jbig2dec-ignore-testtest.patch: Update for new release.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index d007aea6f1..bc1ad88c65 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -479,20 +479,15 @@ arithmetic ops.")
(define-public jbig2dec
(package
(name "jbig2dec")
- (version "0.13")
+ (version "0.14")
(source
(origin
(method url-fetch)
(uri (string-append "http://downloads.ghostscript.com/public/" name "/"
name "-" version ".tar.gz"))
(sha256
- (base32 "04akiwab8iy5iy34razcvh9mcja9wy737civ3sbjxk4j143s1b2s"))
- (patches (search-patches "jbig2dec-ignore-testtest.patch"
- "jbig2dec-CVE-2016-9601.patch"
- "jbig2dec-CVE-2017-7885.patch"
- "jbig2dec-CVE-2017-7975.patch"
- "jbig2dec-CVE-2017-7976.patch"))))
-
+ (base32 "0k01hp0q4275fj4rbr1gy64svfraw5w7wvwl08yjhvsnpb1rid11"))
+ (patches (search-patches "jbig2dec-ignore-testtest.patch"))))
(build-system gnu-build-system)
(synopsis "Decoder of the JBIG2 image compression format")
(description