summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2016-12-15 09:39:30 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-25 13:48:57 +0100
commitd02fb7cec6d74afd3fc24d31afeb7a3731b704e7 (patch)
treec0ca7a1e50fe7119a0c7e0d359324b92fe81e4e1 /gnu/packages/image.scm
parentc88bee0ace137386e9f7c58e1adb72e58ec92767 (diff)
downloadpatches-d02fb7cec6d74afd3fc24d31afeb7a3731b704e7.tar
patches-d02fb7cec6d74afd3fc24d31afeb7a3731b704e7.tar.gz
gnu: leptonica: Update to 1.74.0.
* gnu/packages/image.scm (leptonica): Update to 1.74.0. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm60
1 files changed, 23 insertions, 37 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 487635de15..1c500b3341 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -329,28 +329,23 @@ the W3C's XML-based Scaleable Vector Graphic (SVG) format.")
(define-public leptonica
(package
(name "leptonica")
- (version "1.72")
+ (version "1.74.0")
(source
(origin
(method url-fetch)
- (uri (string-append "http://www.leptonica.com/source/leptonica-"
- version ".tar.gz"))
+ (uri (string-append
+ "https://github.com/DanBloomberg/leptonica/archive/" version
+ ".tar.gz"))
+ (file-name (string-append "leptonica-" version ".tar.gz"))
(sha256
- (base32 "0mhzvqs0im04y1cpcc1yma70hgdac1frf33h73m9z3356bfymmbr"))
- (modules '((guix build utils)))
- ;; zlib and openjpg should be under Libs, not Libs.private. See:
- ;; https://code.google.com/p/tesseract-ocr/issues/detail?id=1436
- (snippet
- '(substitute* "lept.pc.in"
- (("^(Libs\\.private: .*)@ZLIB_LIBS@(.*)" all pre post)
- (string-append pre post))
- (("^(Libs\\.private: .*)@JPEG_LIBS@(.*)" all pre post)
- (string-append pre post))
- (("^Libs: .*" all)
- (string-append all " @ZLIB_LIBS@ @JPEG_LIBS@"))))))
+ (base32 "0i2a4vx9gizki0wgmv03xjz8j9d8agkvbag1a8m4kcw4asd4p87g"))))
(build-system gnu-build-system)
(native-inputs
- `(("gnuplot" ,gnuplot))) ;needed for test suite
+ `(("gnuplot" ,gnuplot) ;needed for test suite
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(inputs
`(("giflib" ,giflib)
("libjpeg" ,libjpeg)
@@ -358,31 +353,22 @@ the W3C's XML-based Scaleable Vector Graphic (SVG) format.")
("libtiff" ,libtiff)
("libwebp" ,libwebp)))
(propagated-inputs
+ ;; Linking a program with leptonica also requires these.
`(("openjpeg" ,openjpeg)
("zlib" ,zlib)))
(arguments
- '(#:parallel-tests? #f ; XXX: cause fpix1_reg to fail
- #:phases
+ '(#:phases
(modify-phases %standard-phases
- ;; Prevent make from trying to regenerate config.h.in.
- (add-after
- 'unpack 'set-config-h-in-file-time
- (lambda _
- (set-file-time "config/config.h.in" (stat "configure"))))
- (add-after
- 'unpack 'patch-reg-wrapper
- (lambda _
- (substitute* "prog/reg_wrapper.sh"
- ((" /bin/sh ")
- (string-append " " (which "sh") " "))
- (("which gnuplot") (which "gnuplot")))))
- (add-before
- 'check 'disable-failing-tests
- ;; XXX: 2 of 9 tests from webpio_reg fails.
- (lambda _
- (substitute* "prog/webpio_reg.c"
- ((".*DoWebpTest2.* 90.*") "")
- ((".*DoWebpTest2.* 100.*") "")))))))
+ (add-after 'unpack 'autogen
+ (lambda _
+ (zero? (system* "sh" "autobuild"))))
+ (add-after 'unpack 'patch-reg-wrapper
+ (lambda _
+ (substitute* "prog/reg_wrapper.sh"
+ ((" /bin/sh ")
+ (string-append " " (which "sh") " "))
+ (("which gnuplot")
+ "true")))))))
(home-page "http://www.leptonica.com/")
(synopsis "Library and tools for image processing and analysis")
(description