summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-25 00:25:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-25 00:25:15 +0200
commit57df83e07d4b5e78d9a54c1a88d05b4a9ed65714 (patch)
tree76684e63965e9ad6e37d9d45bc3159e6c9782cd0 /gnu/packages/image.scm
parent43d9ed7792808638eabb43aa6133f1d6186c520b (diff)
parent136b7d81f0eb713783e9ea7cf7f260a2b6252dfd (diff)
downloadpatches-57df83e07d4b5e78d9a54c1a88d05b4a9ed65714.tar
patches-57df83e07d4b5e78d9a54c1a88d05b4a9ed65714.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index e76661c7d4..c2aae10c87 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -68,6 +68,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (gnu packages qt)
@@ -859,7 +860,7 @@ graphics image formats like PNG, BMP, JPEG, TIFF and others.")
(native-inputs
`(("doxygen" ,doxygen)
("python2-nose" ,python2-nose)
- ("python2-sphinx" ,python2-sphinx)))
+ ("sphinx" ,python-sphinx)))
(arguments
`(#:test-target "check"
#:phases
@@ -1008,9 +1009,9 @@ channels.")
(version "0.26")
(source (origin
(method url-fetch)
- (uri (list (string-append "http://www.exiv2.org/builds/exiv2-"
+ (uri (list (string-append "https://www.exiv2.org/builds/exiv2-"
version "-trunk.tar.gz")
- (string-append "http://www.exiv2.org/exiv2-"
+ (string-append "https://www.exiv2.org/exiv2-"
version ".tar.gz")
(string-append "https://fossies.org/linux/misc/exiv2-"
version ".tar.gz")))
@@ -1026,7 +1027,7 @@ channels.")
("zlib" ,zlib)))
(native-inputs
`(("intltool" ,intltool)))
- (home-page "http://www.exiv2.org/")
+ (home-page "https://www.exiv2.org/")
(synopsis "Library and command-line utility to manage image metadata")
(description
"Exiv2 is a C++ library and a command line utility to manage image
@@ -1131,7 +1132,7 @@ the programmer.")
(home-page "https://github.com/sekrit-twc/zimg")
;; test/extra/ contains musl-libm,
;; which is MIT/expat licensed, but only used for tests
- (license (license:fsf-free "file://COPYING")))) ;WTFPL version 2
+ (license license:wtfpl2)))
(define-public perceptualdiff
(package