aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-11 09:38:49 -0500
committerMark H Weaver <mhw@netris.org>2015-01-11 09:38:49 -0500
commit77448857311318fc9cd866afcb85ca98fccdb25b (patch)
treeefed3a71d1f7b2c2cc292e7e4ba1884c4d26a9e4 /gnu/packages/image.scm
parent62c155c0bcbc0d71b1bc35e966193b6e8de03246 (diff)
parent0009ed71ad288358cbc7828954b5e1a3f18fd525 (diff)
downloadpatches-77448857311318fc9cd866afcb85ca98fccdb25b.tar
patches-77448857311318fc9cd866afcb85ca98fccdb25b.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm25
1 files changed, 19 insertions, 6 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 7a22bf4942..cdb9c1cfb2 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Alex Kost <alezost@gmail.com>
+;;; Copyright © 2014 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -187,16 +188,15 @@ work.")
(define-public openjpeg
(package
(name "openjpeg")
- (version "2.0.0")
+ (version "2.0.1")
(source
(origin
(method url-fetch)
(uri
- (string-append "http://openjpeg.googlecode.com/files/" name "-"
- version ".tar.gz"))
+ (string-append "mirror://sourceforge/openjpeg.mirror/" name "-"
+ version ".tar.gz"))
(sha256
- (base32 "1n05yrmscpgksrh2kfh12h18l0lw9j03mgmvwcg3hm8m0lwgak9k"))))
-
+ (base32 "1c2xc3nl2mg511b63rk7hrckmy14681p1m44mzw3n1fyqnjm0b0z"))))
(build-system cmake-build-system)
(arguments
;; Trying to run `$ make check' results in a no rule fault.
@@ -217,9 +217,22 @@ In addition to the basic codec, various other features are under
development, among them the JP2 and MJ2 (Motion JPEG 2000) file formats,
an indexing tool useful for the JPIP protocol, JPWL-tools for
error-resilience, a Java-viewer for j2k-images, ...")
- (home-page "http://jbig2dec.sourceforge.net/")
+ (home-page "https://code.google.com/p/openjpeg/")
(license license:bsd-2)))
+(define-public openjpeg-1
+ (package (inherit openjpeg)
+ (name "openjpeg")
+ (version "1.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://sourceforge/openjpeg.mirror/" name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "11waq9w215zvzxrpv40afyd18qf79mxc28fda80bm3ax98cpppqm"))))))
+
(define-public giflib
(package
(name "giflib")