summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-25 12:51:50 -0500
committerLeo Famulari <leo@famulari.name>2017-01-25 13:23:25 -0500
commit9b1bb709047f814b89dcba9452e1b21da65e7da3 (patch)
treeb8b592c8bf42a6782deea8c0dd24534aeba97bbd /gnu/packages/image.scm
parent678dd8a5ed34ccc81e2b980e2002cd2afa4a6f71 (diff)
downloadpatches-9b1bb709047f814b89dcba9452e1b21da65e7da3.tar
patches-9b1bb709047f814b89dcba9452e1b21da65e7da3.tar.gz
gnu: libpng: Incorporate grafted patch.
* gnu/packages/image.scm (libpng)[replacement]: Remove field. [source]: Add patch 'libpng-CVE-2016-10087.patch'. (libpng-1.2)[replacement]: Remove field. (libpng/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 54b7dd6e22..c545f026ad 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -65,7 +65,6 @@
(define-public libpng
(package
(name "libpng")
- (replacement libpng/fixed)
(version "1.6.25")
(source (origin
(method url-fetch)
@@ -76,6 +75,7 @@
(string-append
"ftp://ftp.simplesystems.org/pub/libpng/png/src"
"/libpng15/libpng-" version ".tar.xz")))
+ (patches (search-patches "libpng-CVE-2016-10087.patch"))
(sha256
(base32 "04c8inn745hw25wz2dc5vll5n5d2gsndj01i4srwzgz8861qvzh9"))))
(build-system gnu-build-system)
@@ -90,18 +90,9 @@ library. It supports almost all PNG features and is extensible.")
(license license:zlib)
(home-page "http://www.libpng.org/pub/png/libpng.html")))
-(define libpng/fixed
- (package
- (inherit libpng)
- (source
- (origin
- (inherit (package-source libpng))
- (patches (search-patches "libpng-CVE-2016-10087.patch"))))))
-
(define-public libpng-1.2
(package
(inherit libpng)
- (replacement #f)
(version "1.2.57")
(source
(origin