summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-24 00:12:00 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-24 00:12:00 +0100
commit77ab6983a19ef307558ab2607920158d6bb94ba8 (patch)
tree71ffa825049449679ec81b1092432d15764db503 /gnu/packages/image.scm
parent7fdca77e007f0838ecd32b044827678f2b345ff0 (diff)
downloadpatches-77ab6983a19ef307558ab2607920158d6bb94ba8.tar
patches-77ab6983a19ef307558ab2607920158d6bb94ba8.tar.gz
gnu: devil: Update to 1.8.0.
* gnu/packages/patches/devil-CVE-2009-3994.patch, gnu/packages/patches/devil-fix-libpng.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. * gnu/packages/image.scm (devil): Update to 1.8.0. [source]: Remove patches and snippet. [build-system]: Change to CMAKE-BUILD-SYSTEM. [arguments]: Disable tests. Remove #:configure-flags and add a 'change-directory' phase. Remove 'fix-tests' phase. [inputs]: Change LIBJPEG to LIBJPEG-TURBO.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm34
1 files changed, 9 insertions, 25 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 51c465a0cc..51b09680a9 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -860,44 +860,28 @@ and XMP metadata of images in various formats.")
(define-public devil
(package
(name "devil")
- (version "1.7.8")
+ (version "1.8.0")
(source (origin
(method url-fetch)
(uri (string-append "http://downloads.sourceforge.net/openil/"
"DevIL-" version ".tar.gz"))
(sha256
(base32
- "1zd850nn7nvkkhasrv7kn17kzgslr5ry933v6db62s4lr0zzlbv8"))
- ;; Backported from upstream:
- ;; https://github.com/DentonW/DevIL/commit/724194d7a9a91221a564579f64bdd6f0abd64219.patch
- (patches (search-patches "devil-fix-libpng.patch"
- "devil-CVE-2009-3994.patch"))
- (modules '((guix build utils)))
- (snippet
- ;; Fix old lcms include directives and lib flags.
- '(substitute* '("configure" "src-IL/src/il_profiles.c")
- (("-llcms") "-llcms2")
- (("lcms/lcms\\.h") "lcms2/lcms2.h")
- (("lcms\\.h") "lcms2.h")))))
- (build-system gnu-build-system)
+ "02dpzvi493r09c9hfjnk54nladl3qw55iqkkg18g12fxwwz9fx80"))))
+ (build-system cmake-build-system)
(arguments
- '(#:configure-flags '("--enable-ILUT=yes") ; build utility library
+ '(;; XXX: Not supported in the released CMakeLists.txt.
+ ;; Enable this for > 1.8.0.
+ #:tests? #f
#:phases
(modify-phases %standard-phases
- (add-before 'check 'fix-tests
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Fix hard-coded /bin/bash reference.
- (substitute* '("test/Makefile")
- (("TESTS_ENVIRONMENT = /bin/bash")
- (string-append "TESTS_ENVIRONMENT = "
- (assoc-ref inputs "bash")
- "/bin/bash")))
- #t)))))
+ (add-before 'configure 'change-directory
+ (lambda _ (chdir "DevIL") #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
`(("lcms" ,lcms)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("libmng" ,libmng)
("libpng" ,libpng)
("libtiff" ,libtiff)