summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-01-19 23:59:20 -0500
committerMark H Weaver <mhw@netris.org>2018-01-19 23:59:20 -0500
commite074a655dd6497daafbd62737e3b63f3d5aa7985 (patch)
tree2b198ba5c664cdd58e155f3c0113d1cebde0fc91 /gnu/packages/image-viewers.scm
parent6d7b26a39faf42c37f15dc64a30a77e5e194ea23 (diff)
parentccb5cac17be98aaa9c3225605d6170c675d8e8e6 (diff)
downloadpatches-e074a655dd6497daafbd62737e3b63f3d5aa7985.tar
patches-e074a655dd6497daafbd62737e3b63f3d5aa7985.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm32
1 files changed, 22 insertions, 10 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index bb1b973145..be7a1e9ba3 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 nee <nee-git@hidamari.blue>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,6 +37,7 @@
#:use-module (gnu packages boost)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages fontutils)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -172,7 +174,7 @@ It is the default image viewer on LXDE desktop environment.")
(define-public sxiv
(package
(name "sxiv")
- (version "1.3.2")
+ (version "24")
(source (origin
(method url-fetch)
(uri (string-append
@@ -181,19 +183,29 @@ It is the default image viewer on LXDE desktop environment.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0lxnd33gaw4drhdwbkk94wzrjyhh64d57jq2ps7ffmqgizg6hlwz"))))
+ "044i077li6m4zsz2fswlcdi2m0sbr9mwws1h3k1zjaln29fw87ai"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ; no check target
- #:make-flags (list (string-append "PREFIX=" %output)
- "CC=gcc")
- ;; no configure phase
- #:phases (modify-phases %standard-phases (delete 'configure))))
+ `(#:tests? #f ; no check target
+ #:make-flags
+ (list (string-append "PREFIX=" %output)
+ "CC=gcc"
+ ;; Xft.h #includes <ft2build.h> (without ‘freetype2/’). The sxiv
+ ;; Makefile works around this by hard-coding /usr/include instead.
+ (string-append "DEF_CPPFLAGS=-I"
+ (assoc-ref %build-inputs "freetype")
+ "/include/freetype2")
+ "V=1")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
(inputs
- `(("libx11" ,libx11)
- ("imlib2" ,imlib2)
+ `(("freetype" ,freetype)
("giflib" ,giflib)
- ("libexif" ,libexif)))
+ ("imlib2" ,imlib2)
+ ("libexif" ,libexif)
+ ("libx11" ,libx11)
+ ("libxft" ,libxft)))
(home-page "https://github.com/muennich/sxiv")
(synopsis "Simple X Image Viewer")
(description