summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-04-06 14:58:19 +0200
committerLudovic Courtès <ludo@gnu.org>2020-04-11 19:22:26 +0200
commit62a3bbfdfef42b8aa0b8a04bbf62c9f845903da9 (patch)
tree1e8dd9f3f45c8d96cce33d2fd35f0b3ad76adb12 /gnu/packages/hurd.scm
parent29505c7d1eb08afc14a881d84705cde54b12192f (diff)
downloadpatches-62a3bbfdfef42b8aa0b8a04bbf62c9f845903da9.tar
patches-62a3bbfdfef42b8aa0b8a04bbf62c9f845903da9.tar.gz
gnu: hurd: Install the UTF-8 motd.
* gnu/packages/hurd.scm (hurd)[arguments]: Add 'install-goodies' phase.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 45e1b21a77..e5ad8e4f73 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -409,6 +409,16 @@ fsysopts / --writable\n"))
(patch-shebang file path))
(find-files (string-append out "/libexec")))
#t)))
+ (add-after 'install 'install-goodies
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Install additional goodies.
+ ;; TODO: Build & install *.msgids for rpctrace.
+ (let ((out (assoc-ref outputs "out")))
+ ;; Install the fancy UTF-8 motd.
+ (mkdir-p (string-append out "/etc"))
+ (copy-file "console/motd.UTF8"
+ (string-append out "/etc/motd"))
+ #t)))
(add-after 'install 'install-rc-file
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))