summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2017-04-08 16:58:04 +0300
committerManolis Ragkousis <manolis837@gmail.com>2017-04-22 23:01:30 +0300
commitcc4faa35f8fa8a64e39c62e77128ad880d0173fd (patch)
tree030f9ae99962c94dbe34288ce49989cc37143445 /gnu/packages/hurd.scm
parentb005a37ac23f97d6859152c2a86b7af5d26ebd5c (diff)
downloadpatches-cc4faa35f8fa8a64e39c62e77128ad880d0173fd.tar
patches-cc4faa35f8fa8a64e39c62e77128ad880d0173fd.tar.gz
gnu: Add the Hurd.
* gnu/packages/hurd.scm (hurd): New variable. * gnu/packages/patches/hurd-fix-eth-multiplexer-dependency.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 12fce5453d..bd1eb4b085 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -245,3 +245,44 @@ Hurd-minimal package which are needed for both glibc and GCC.")
(description
"GNU Mach is the microkernel upon which a GNU Hurd system is based.")
(license gpl2+)))
+
+(define-public hurd
+ (package
+ (name "hurd")
+ (version "0.9")
+ (source (origin
+ (method url-fetch)
+ (uri (hurd-source-url version))
+ (sha256
+ (base32
+ "1nw9gly0n7pyv3cpfm4mmxy4yccrx4g0lyrvd3vk2vil26jpbggw"))
+ (patches (search-patches "hurd-fix-eth-multiplexer-dependency.patch"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'pre-build
+ (lambda _
+ ;; Don't change the ownership of any file at this time.
+ (substitute* '("daemons/Makefile" "utils/Makefile")
+ (("-o root -m 4755") ""))
+ #t)))
+ #:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+ %output "/lib")
+ "--disable-ncursesw"
+ "--without-libbz2"
+ "--without-libz"
+ "--without-parted")))
+ (build-system gnu-build-system)
+ (inputs `(("glibc-hurd-headers" ,glibc/hurd-headers)))
+ (native-inputs
+ `(("mig" ,mig)
+ ("perl" ,perl)))
+ (supported-systems %hurd-systems)
+ (home-page "https://www.gnu.org/software/hurd/hurd.html")
+ (synopsis "The kernel servers for the GNU operating system")
+ (description
+ "The Hurd is the kernel for the GNU system, a replacement and
+augmentation of standard Unix kernels. It is a collection of protocols for
+system interaction (file systems, networks, authentication), and servers
+implementing them.")
+ (license gpl2+)))