summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2018-03-21 03:44:56 +0000
committerLudovic Courtès <ludo@gnu.org>2018-03-31 19:27:23 +0200
commitff7dd11f0a4fd6ca947cfa40cec42628fde44667 (patch)
treeb5a7f29f109c8aa8a15d92a2ae4811a5972ac05e /gnu/packages/haskell.scm
parentac7cdb40abc50622f8e60cd9891bb8424d739503 (diff)
downloadpatches-ff7dd11f0a4fd6ca947cfa40cec42628fde44667.tar
patches-ff7dd11f0a4fd6ca947cfa40cec42628fde44667.tar.gz
gnu: Add ghc-th-lift-instances.
* gnu/packages/haskell.scm (ghc-th-lift-instances): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 7909b3e6af..856d017686 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9052,4 +9052,29 @@ connections.")
from aeson.")
(license license:bsd-3)))
+(define-public ghc-th-lift-instances
+ (package
+ (name "ghc-th-lift-instances")
+ (version "0.1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "th-lift-instances-" version "/"
+ "th-lift-instances-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1f56cp6ckcalld5jchv0kxpjkwcsixd7smd0g7r8cg67ppx6m90x"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-th-lift" ,ghc-th-lift)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-text" ,ghc-text)))
+ (native-inputs `(("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "https://github.com/bennofs/th-lift-instances")
+ (synopsis "Lift instances for template-haskell for common data types")
+ (description "Most data types in the Haskell platform do not have Lift
+instances. This package provides orphan instances for containers, text,
+bytestring and vector.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here