summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2018-03-21 03:45:06 +0000
committerLudovic Courtès <ludo@gnu.org>2018-03-31 19:27:43 +0200
commit82e0b0e23f180494cfa61084e912b07cca60743f (patch)
treea8041438fd93cdcebfa5ecda4277178a99ef952e /gnu/packages/haskell.scm
parent1c225fabd6c6b1a3876e30ed1443d8b0d1dce8d8 (diff)
downloadpatches-82e0b0e23f180494cfa61084e912b07cca60743f.tar
patches-82e0b0e23f180494cfa61084e912b07cca60743f.tar.gz
gnu: Add ghc-microlens-th.
* gnu/packages/haskell.scm (ghc-microlens-th): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 08e357a68e..7cf152d1bf 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9346,4 +9346,29 @@ combinators (like @code{failing} and @code{singular}), but everything else is
stripped. As the result, this package has no dependencies.")
(license license:bsd-3)))
+(define-public ghc-microlens-th
+ (package
+ (name "ghc-microlens-th")
+ (version "0.4.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "microlens-th-" version "/"
+ "microlens-th-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15a12cqxlgbcn1n73zwrxnp2vfm8b0ma0a0sdd8zmjbs8zy3np4f"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-microlens" ,ghc-microlens)))
+ (home-page
+ "https://github.com/aelve/microlens")
+ (synopsis "Automatic generation of record lenses for
+@code{ghc-microlens}")
+ (description "This Haskell package lets you automatically generate lenses
+for data types; code was extracted from the lens package, and therefore
+generated lenses are fully compatible with ones generated by lens (and can be
+used both from lens and microlens).")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here