summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-01-14 05:24:09 -0500
committerMark H Weaver <mhw@netris.org>2017-01-14 05:24:09 -0500
commit5827ea30ee64f2981929f865cf4c07e6c4712773 (patch)
tree31b6505f4ad9b53860028d2e47db62c34c15e484 /gnu/packages/haskell.scm
parent57203ebba0fa3eaa7c2df9bfd3e7c59f8ee98f6a (diff)
parentdd42a330d1301fd34f36dada9d142006165abaef (diff)
downloadpatches-5827ea30ee64f2981929f865cf4c07e6c4712773.tar
patches-5827ea30ee64f2981929f865cf4c07e6c4712773.tar.gz
Merge branch 'master' into gnome-updates
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm37
1 files changed, 33 insertions, 4 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8f8e2f5d5e..b26234d405 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3052,7 +3052,7 @@ use HUnit assertions as QuickCheck properties.")
(define-public ghc-quickcheck
(package
(name "ghc-quickcheck")
- (version "2.8.1")
+ (version "2.8.2")
(outputs '("out" "doc"))
(source
(origin
@@ -3063,7 +3063,7 @@ use HUnit assertions as QuickCheck properties.")
".tar.gz"))
(sha256
(base32
- "0fvnfl30fxmj5q920l13641ar896d53z0z6z66m7c1366lvalwvh"))))
+ "1ai6k5v0bibaxq8xffcblc6rwmmk6gf8vjyd9p2h3y6vwbhlvilq"))))
(build-system haskell-build-system)
(arguments
`(#:tests? #f ; FIXME: currently missing libraries used for tests.
@@ -4573,7 +4573,7 @@ just a @code{Semigroup} are added.")
(define-public ghc-semigroups
(package
(name "ghc-semigroups")
- (version "0.17.0.1")
+ (version "0.18.2")
(source
(origin
(method url-fetch)
@@ -4583,7 +4583,7 @@ just a @code{Semigroup} are added.")
".tar.gz"))
(sha256
(base32
- "0gvpfi7s6ys4qha3y9a1zl1a15gf9cgg33wjb94ghg82ivcxnc3r"))))
+ "1r6hsn3am3dpf4rprrj4m04d9318v9iq02bin0pl29dg4a3gzjax"))))
(build-system haskell-build-system)
(inputs
`(("ghc-nats" ,ghc-nats)
@@ -8133,4 +8133,33 @@ Rust syntax. It is intended to be useful for two different purposes:
@end enumerate\n")
(license license:gpl2+))))
+(define-public ghc-wave
+ (package
+ (name "ghc-wave")
+ (version "0.1.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/wave/wave-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1g5nmqfk6p25v9ismwz4i66ay91bd1qh39xwj0hm4z6a5mw8frk8"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-cereal" ,ghc-cereal)
+ ("ghc-data-default-class"
+ ,ghc-data-default-class)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-temporary" ,ghc-temporary)))
+ (native-inputs
+ `(("hspec-discover" ,hspec-discover)
+ ("ghc-hspec" ,ghc-hspec)))
+ (home-page "https://github.com/mrkkrp/wave")
+ (synopsis "Work with WAVE and RF64 files in Haskell")
+ (description "This package allows you to work with WAVE and RF64
+files in Haskell.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here