summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-06-20 07:57:01 +0200
committerTimothy Sample <samplet@ngyro.com>2019-07-19 23:09:49 -0400
commitca20ee07b2ef05f37fc870c29439b3c980669ac4 (patch)
treebd03efe306d1a7f7e5e8c1c5453e97689135a3a3 /gnu/packages/haskell.scm
parentefc55bf6f3d2984dba00fbfa6f10a3e8f9e44146 (diff)
downloadpatches-ca20ee07b2ef05f37fc870c29439b3c980669ac4.tar
patches-ca20ee07b2ef05f37fc870c29439b3c980669ac4.tar.gz
gnu: Add ghc-path-io.
* gnu/packages/haskell.scm (ghc-path-io): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9bbf0878c6..2aaa0585dd 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11691,6 +11691,42 @@ explicit by providing a function to check whether the invariants hold.")
invariants.")
(license license:bsd-3)))
+(define-public ghc-path-io
+ (package
+ (name "ghc-path-io")
+ (version "1.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/path-io/path-io-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1g9m3qliqjk1img894wsb89diym5zrq51qkkrwhz4sbm9a8hbv1a"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-dlist" ,ghc-dlist)
+ ("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-path" ,ghc-path)
+ ("ghc-transformers-base" ,ghc-transformers-base)
+ ("ghc-unix-compat" ,ghc-unix-compat)
+ ("ghc-temporary" ,ghc-temporary)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)))
+ (arguments
+ `(#:cabal-revision
+ ("3" "1h9hsibbflkxpjl2fqamqiv3x3gasf51apnmklrs9l9x8r32hzcc")))
+ (home-page
+ "https://github.com/mrkkrp/path-io")
+ (synopsis "Functions for manipulating well-typed paths")
+ (description "This package provides an interface to the @code{directory}
+package for users of @code{path}. It also implements some missing stuff like
+recursive scanning and copying of directories, working with temporary
+files/directories, and more.")
+ (license license:bsd-3)))
+
(define-public ghc-stylish-haskell
(package
(name "ghc-stylish-haskell")