aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 15:20:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 15:20:25 +0100
commit02d38bd3a2c964698ef08524d6313b726ce63846 (patch)
tree94a0e57b2e017ba80a9f7309aae241862ea2e81f /gnu/packages/haskell.scm
parent2b965485e2f3a8755efff58fc1abad75df3e37a0 (diff)
parent776248419fe521afe9c6dd4b2fac6fc4b8b18e9b (diff)
downloadpatches-02d38bd3a2c964698ef08524d6313b726ce63846.tar
patches-02d38bd3a2c964698ef08524d6313b726ce63846.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm90
1 files changed, 90 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9433ae0570..255e902e66 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11403,4 +11403,94 @@ from a shell. The @code{tldr} pages are a community effort to simplify the
man pages with practical examples.")
(license license:bsd-3)))
+(define-public ghc-c2hs
+ (package
+ (name "ghc-c2hs")
+ (version "0.28.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/c2hs/c2hs-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1nplgxfin139x12sb656f5870rpdclrhzi8mq8pry035qld15pci"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-language-c" ,ghc-language-c)
+ ("ghc-dlist" ,ghc-dlist)))
+ (native-inputs
+ `(("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-shelly" ,ghc-shelly)
+ ("ghc-text" ,ghc-text)
+ ("gcc" ,gcc)))
+ (arguments
+ `(;; XXX: Test failures are induced by a parse error in <bits/floatn.h>
+ ;; of glibc 2.28.
+ #:tests? #f
+
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-cc
+ ;; add a cc executable in the path, needed for some tests to pass
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((gcc (assoc-ref inputs "gcc"))
+ (tmpbin (tmpnam))
+ (curpath (getenv "PATH")))
+ (mkdir-p tmpbin)
+ (symlink (which "gcc") (string-append tmpbin "/cc"))
+ (setenv "PATH" (string-append tmpbin ":" curpath)))
+ #t))
+ (add-after 'check 'remove-cc
+ ;; clean the tmp dir made in 'set-cc
+ (lambda _
+ (let* ((cc-path (which "cc"))
+ (cc-dir (dirname cc-path)))
+ (delete-file-recursively cc-dir)
+ #t))))))
+ (home-page "https://github.com/haskell/c2hs")
+ (synopsis "Create Haskell bindings to C libraries")
+ (description "C->Haskell assists in the development of Haskell bindings to
+C libraries. It extracts interface information from C header files and
+generates Haskell code with foreign imports and marshaling. Unlike writing
+foreign imports by hand (or using hsc2hs), this ensures that C functions are
+imported with the correct Haskell types.")
+ (license license:gpl2)))
+
+(define-public ghc-libmpd
+ (package
+ (name "ghc-libmpd")
+ (version "0.9.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/libmpd/libmpd-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1931m23iqb4wddpdidm4ph746zpaw41kkjzmb074j7yyfpk7x1jv"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-old-locale" ,ghc-old-locale)
+ ("ghc-text" ,ghc-text)
+ ("ghc-data-default-class" ,ghc-data-default-class)
+ ("ghc-network" ,ghc-network)
+ ("ghc-utf8-string" ,ghc-utf8-string)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hspec" ,ghc-hspec)
+ ("hspec-discover" ,hspec-discover)))
+ (home-page "https://github.com/vimus/libmpd-haskell")
+ (synopsis "Haskell client library for the Music Player Daemon")
+ (description "This package provides a pure Haskell client library for the
+Music Player Daemon.")
+ (license license:expat)))
+
;;; haskell.scm ends here