summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 13:36:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:41 +0100
commitaeecabd43ce4b3c6b6c505e21f59fc720cc18a2c (patch)
treee246d53c483419aa87018a750ba316d450362959 /gnu/packages/haskell.scm
parentf941a52a14a69b69414a3d6b8487676cfe5cbb58 (diff)
downloadpatches-aeecabd43ce4b3c6b6c505e21f59fc720cc18a2c.tar
patches-aeecabd43ce4b3c6b6c505e21f59fc720cc18a2c.tar.gz
gnu: Add ghc-parser-combinators.
* gnu/packages/haskell.scm (ghc-parser-combinators): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index ac735ca9ea..b13e7a5b7c 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3448,6 +3448,27 @@ defined as a monad transformer that can be stacked on arbitrary monads, and it
is also parametric in the input stream type.")
(license license:bsd-3)))
+(define-public ghc-parser-combinators
+ (package
+ (name "ghc-parser-combinators")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "parser-combinators/parser-combinators-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1azkz0a6ikym02s8wydjcklp7rz8k512bs4s9lp9g1g03m0yj95i"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/mrkkrp/parser-combinators")
+ (synopsis "Commonly useful parser combinators")
+ (description
+ "This is a lightweight package providing commonly useful parser
+combinators.")
+ (license license:bsd-3)))
+
(define-public ghc-vector
(package
(name "ghc-vector")