summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 11:13:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:40 +0100
commit32ddba787a14a6ea17afa4e265cdf07cc8e8fbb7 (patch)
tree07ad8b065870466c3a2478875d0f29101c54ffeb /gnu/packages/haskell.scm
parenta54b7441266b3c87a3a724518f31af71d190a8ab (diff)
downloadpatches-32ddba787a14a6ea17afa4e265cdf07cc8e8fbb7.tar
patches-32ddba787a14a6ea17afa4e265cdf07cc8e8fbb7.tar.gz
gnu: Add ghc-call-stack.
* gnu/packages/haskell.scm (ghc-call-stack): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a3e5307378..f733337ae4 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4188,6 +4188,27 @@ given term should not exist.")
forms of the Yoneda lemma, and (co)density (co)monads for Haskell.")
(license license:bsd-3)))
+(define-public ghc-call-stack
+ (package
+ (name "ghc-call-stack")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "call-stack/call-stack-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1qmihf5jafmc79sk52l6gpx75f5bnla2lp62kh3p34x3j84mwpzj"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-nanospec" ,ghc-nanospec)))
+ (home-page "https://github.com/sol/call-stack#readme")
+ (synopsis "Use GHC call-stacks in a backward compatible way")
+ (description "This package provides a compatibility layer for using GHC
+call stacks with different versions of the compiler.")
+ (license license:expat)))
+
(define-public ghc-statevar
(package
(name "ghc-statevar")