summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2018-09-30 20:05:55 +0800
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:23 +0200
commiteaa1f873e69c64e5d7f7535e95f6ae0be75c3ac9 (patch)
tree1154d2446b7242abb144a85a090254ba61960ef7 /gnu/packages/haskell.scm
parentf0bce3a758a6cc66552f326e570b571e0155814a (diff)
downloadpatches-eaa1f873e69c64e5d7f7535e95f6ae0be75c3ac9.tar
patches-eaa1f873e69c64e5d7f7535e95f6ae0be75c3ac9.tar.gz
gnu: shellcheck: Update to 0.5.0.
* gnu/packages/haskell.scm (shellcheck): Update to 0.5.0. [source]: Use tarball from hackage. [inputs]: Add ghc-aeson. Remove ghc-json.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0e2dfd8817..df0190d591 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8489,20 +8489,21 @@ generated SQL and optimize it for your backend.")
(define-public shellcheck
(package
(name "shellcheck")
- (version "0.4.6")
+ (version "0.5.0")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/koalaman/shellcheck/archive/"
- "v" version ".tar.gz"))
+ (uri (string-append
+ "https://hackage.haskell.org/package/ShellCheck/ShellCheck-"
+ version ".tar.gz"))
(sha256
(base32
- "1qkd69lc34n3l23ss9rq1azvx49bfq4hi4bmaj76rgxybscxhg0w"))
+ "0z1hscbr11hwkq8k1v0vaa947hb9m6k4cm831jk1gpj8dxrk151b"))
(file-name (string-append name "-" version ".tar.gz"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-quickcheck" ,ghc-quickcheck)
- ("ghc-json" ,ghc-json)
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-quickcheck" ,ghc-quickcheck)
("ghc-parsec" ,ghc-parsec)
("ghc-regex-tdfa" ,ghc-regex-tdfa)))
(home-page "https://github.com/koalaman/shellcheck")