summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-01 00:18:38 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:22 +0200
commitc6cf0eb5fb7bd1a77164293b727d1bc0d678d64c (patch)
tree663255a9abfd371fb4e6cc84d259e95680d53392 /gnu/packages/haskell.scm
parent7eee87e65d9e2da183887ade425a29de1a1f024d (diff)
downloadpatches-c6cf0eb5fb7bd1a77164293b727d1bc0d678d64c.tar
patches-c6cf0eb5fb7bd1a77164293b727d1bc0d678d64c.tar.gz
gnu: Add ghc-tree-diff.
* gnu/packages/haskell.scm (ghc-tree-diff): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a373de8ea4..ed83ece155 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -872,6 +872,66 @@ and an alternative to newtype-th.")
efficient memo functions using tries.")
(license license:bsd-3)))
+(define-public ghc-tree-diff
+ (package
+ (name "ghc-tree-diff")
+ (version "0.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/tree-diff/tree-diff-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "049v44c520jy3icxlnrvbdblh3mjmvd7m6qmkzxbzkf02x63xqmz"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:cabal-revision
+ ("4" "1rqxxyj6hqllahs11693g855cxz8mgnb490s7j1ksd300i5xgjsp")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'update-constraints
+ (lambda _
+ (substitute* "tree-diff.cabal"
+ (("trifecta >=1\\.7\\.1\\.1 && <1\\.8")
+ "trifecta >=1.7.1.1 && <=2")))))))
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)
+ ("ghc-ansi-terminal" ,ghc-ansi-terminal)
+ ("ghc-base-compat" ,ghc-base-compat)
+ ("ghc-generics-sop" ,ghc-generics-sop)
+ ("ghc-hashable" ,ghc-hashable)
+ ("ghc-memotrie" ,ghc-memotrie)
+ ("ghc-parsec" ,ghc-parsec)
+ ("ghc-parsers" ,ghc-parsers)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-tagged" ,ghc-tagged)
+ ("ghc-text" ,ghc-text)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-uuid-types" ,ghc-uuid-types)
+ ("ghc-vector" ,ghc-vector)))
+ (native-inputs
+ `(("ghc-base-compat" ,ghc-base-compat)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-ansi-terminal" ,ghc-ansi-terminal)
+ ("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)
+ ("ghc-parsec" ,ghc-parsec)
+ ("ghc-trifecta" ,ghc-trifecta)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-golden" ,ghc-tasty-golden)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+ (home-page "https://github.com/phadej/tree-diff")
+ (synopsis "Compute difference between (expression) trees")
+ (description "This Haskell library provides a function for computing
+the difference bewteen (expression) trees. It also provides a way to
+compute the difference between arbitrary abstract datatypes (ADTs) using
+@code{Generics}-derivable helpers.")
+ (license license:bsd-3)))
+
(define-public ghc-haddock-library
(package
(name "ghc-haddock-library")