summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-29 01:14:08 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:21 +0200
commitb9f67d10bcbd969884e3f579d1dd9ff585b2016a (patch)
tree85582a4b410c51a086617900ee5ba2c2a8a61816 /gnu/packages/haskell.scm
parentfbdf4031891fa1f0c5a82b9c7c773bcb64ea40b2 (diff)
downloadpatches-b9f67d10bcbd969884e3f579d1dd9ff585b2016a.tar
patches-b9f67d10bcbd969884e3f579d1dd9ff585b2016a.tar.gz
gnu: ghc-lens: Update to 4.16.1.
* gnu/packages/haskell.scm (ghc-lens): Update to 4.16.1. [arguments]: Update Cabal file to r2. [inputs]: Remove ghc-doctest-0.13. [native-inputs]: Add ghc-doctest.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2347a4deb1..351420c108 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4971,7 +4971,7 @@ in the @code{IO} monad, like @code{IORef}s or parts of the OpenGL state.")
(define-public ghc-lens
(package
(name "ghc-lens")
- (version "4.15.4")
+ (version "4.16.1")
(source
(origin
(method url-fetch)
@@ -4979,12 +4979,14 @@ in the @code{IO} monad, like @code{IORef}s or parts of the OpenGL state.")
version ".tar.gz"))
(sha256
(base32
- "1lkwlnhgpgnsz046mw4qs0fa7h4l012gilrr3nf3spllsy3pnbkl"))))
+ "1im4drhbydbawd6i0jsrzpqihnmx4ywpkg7yg94ddwsw3mxwkgpm"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:cabal-revision
+ ("2" "11h83lj5mba4grhz1qx3irz10ysm9c3k7k6i6xv2cr60q8xin3ri")))
(inputs
`(("ghc-base-orphans" ,ghc-base-orphans)
("ghc-bifunctors" ,ghc-bifunctors)
- ("ghc-doctest" ,ghc-doctest-0.13)
("ghc-distributive" ,ghc-distributive)
("ghc-exceptions" ,ghc-exceptions)
("ghc-free" ,ghc-free)
@@ -5010,6 +5012,7 @@ in the @code{IO} monad, like @code{IORef}s or parts of the OpenGL state.")
("hlint" ,hlint)))
(native-inputs
`(("cabal-doctest" ,cabal-doctest)
+ ("ghc-doctest" ,ghc-doctest)
("ghc-hunit" ,ghc-hunit)
("ghc-test-framework" ,ghc-test-framework)
("ghc-test-framework-hunit" ,ghc-test-framework-hunit)