summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 11:35:40 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:40 +0100
commit1afa5abbe8f3716967565f62ac005a9e091ea97d (patch)
tree43382dbf59624302b20c9aeec99a9a2bf9e0a21f /gnu/packages/haskell.scm
parent009d0f6d74a8ef7d188ad2d2b320ceb40454f9d4 (diff)
downloadpatches-1afa5abbe8f3716967565f62ac005a9e091ea97d.tar
patches-1afa5abbe8f3716967565f62ac005a9e091ea97d.tar.gz
gnu: ghc-pandoc: Update to 2.0.6.
* gnu/packages/haskell.scm (ghc-pandoc): Update to 2.0.6. [inputs]: Add ghc-aeson-pretty, ghc-cmark-gfm, ghc-doctemplates, ghc-glob, ghc-hslua-module-text, ghc-old-locale, ghc-skylighting, and ghc-split; remove ghc-ansi-terminal, ghc-cmark, ghc-extensible-exceptions, ghc-filemanip, ghc-highlighting-kate, and ghc-old-time. [native-inputs]: Remove ghc-test-framework, ghc-test-framework-hunit, and ghc-test-framework-quickcheck2; add ghc-tasty, ghc-tasty-golden, ghc-tasty-hunit, and ghc-tasty-quickcheck.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm79
1 files changed, 41 insertions, 38 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9741d94d18..c15a29368b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5837,7 +5837,7 @@ provided. Skylighting is intended to be the successor to highlighting-kate.")
(define-public ghc-pandoc
(package
(name "ghc-pandoc")
- (version "1.17.2")
+ (version "2.0.6")
(source
(origin
(method url-fetch)
@@ -5845,53 +5845,56 @@ provided. Skylighting is intended to be the successor to highlighting-kate.")
version ".tar.gz"))
(sha256
(base32
- "1v78zq12p71gq0pc24h08inxcq5gxd0xb7m5ds0xw9pv9l2pswl1"))))
+ "1vhj6splykksb1mkxv5cs0361nj12qn23a3y1i8j5dc637lkdwpj"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-syb" ,ghc-syb)
- ("ghc-unordered-containers" ,ghc-unordered-containers)
- ("ghc-parsec" ,ghc-parsec)
- ("ghc-mtl" ,ghc-mtl)
- ("ghc-text" ,ghc-text)
- ("ghc-zip-archive" ,ghc-zip-archive)
- ("ghc-http" ,ghc-http)
- ("ghc-texmath" ,ghc-texmath)
- ("ghc-xml" ,ghc-xml)
- ("ghc-random" ,ghc-random)
- ("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
- ("ghc-pandoc-types" ,ghc-pandoc-types)
- ("ghc-aeson" ,ghc-aeson)
- ("ghc-tagsoup" ,ghc-tagsoup)
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-aeson-pretty" ,ghc-aeson-pretty)
("ghc-base64-bytestring" ,ghc-base64-bytestring)
- ("ghc-zlib" ,ghc-zlib)
- ("ghc-highlighting-kate" ,ghc-highlighting-kate)
- ("ghc-data-default" ,ghc-data-default)
- ("ghc-temporary" ,ghc-temporary)
("ghc-blaze-html" ,ghc-blaze-html)
("ghc-blaze-markup" ,ghc-blaze-markup)
- ("ghc-yaml" ,ghc-yaml)
- ("ghc-scientific" ,ghc-scientific)
- ("ghc-vector" ,ghc-vector)
- ("ghc-hslua" ,ghc-hslua)
- ("ghc-sha" ,ghc-sha)
- ("ghc-haddock-library" ,ghc-haddock-library)
- ("ghc-old-time" ,ghc-old-time)
+ ("ghc-cmark-gfm" ,ghc-cmark-gfm)
+ ("ghc-data-default" ,ghc-data-default)
("ghc-deepseq-generics" ,ghc-deepseq-generics)
- ("ghc-juicypixels" ,ghc-juicypixels)
- ("ghc-filemanip" ,ghc-filemanip)
- ("ghc-cmark" ,ghc-cmark)
- ("ghc-network-uri" ,ghc-network-uri)
- ("ghc-network" ,ghc-network)
+ ("ghc-diff" ,ghc-diff)
+ ("ghc-doctemplates" ,ghc-doctemplates)
+ ("ghc-executable-path" ,ghc-executable-path)
+ ("ghc-glob" ,ghc-glob)
+ ("ghc-haddock-library" ,ghc-haddock-library)
+ ("ghc-hslua" ,ghc-hslua)
+ ("ghc-hslua-module-text" ,ghc-hslua-module-text)
+ ("ghc-http" ,ghc-http)
("ghc-http-client" ,ghc-http-client)
("ghc-http-client-tls" ,ghc-http-client-tls)
("ghc-http-types" ,ghc-http-types)
- ("ghc-diff" ,ghc-diff)
- ("ghc-ansi-terminal" ,ghc-ansi-terminal)
- ("ghc-executable-path" ,ghc-executable-path)))
+ ("ghc-juicypixels" ,ghc-juicypixels)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-network" ,ghc-network)
+ ("ghc-network-uri" ,ghc-network-uri)
+ ("ghc-old-locale" ,ghc-old-locale)
+ ("ghc-pandoc-types" ,ghc-pandoc-types)
+ ("ghc-parsec" ,ghc-parsec)
+ ("ghc-random" ,ghc-random)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-sha" ,ghc-sha)
+ ("ghc-skylighting" ,ghc-skylighting)
+ ("ghc-split" ,ghc-split)
+ ("ghc-syb" ,ghc-syb)
+ ("ghc-tagsoup" ,ghc-tagsoup)
+ ("ghc-temporary" ,ghc-temporary)
+ ("ghc-texmath" ,ghc-texmath)
+ ("ghc-text" ,ghc-text)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-xml" ,ghc-xml)
+ ("ghc-yaml" ,ghc-yaml)
+ ("ghc-zip-archive" ,ghc-zip-archive)
+ ("ghc-zlib" ,ghc-zlib)))
(native-inputs
- `(("ghc-test-framework" ,ghc-test-framework)
- ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
- ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-golden" ,ghc-tasty-golden)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
("ghc-quickcheck" ,ghc-quickcheck)
("ghc-hunit" ,ghc-hunit)))
(home-page "http://pandoc.org")