summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-03-27 18:20:18 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-04-08 17:31:13 +0200
commitd692228e8b47d40ce9c0b3fa74742eab138df419 (patch)
treeeb81ca561df15568a0845a68f5c15915f494712a /gnu/packages/haskell.scm
parent01a687da098510547f52a066738ca0d3f85ebc45 (diff)
downloadpatches-d692228e8b47d40ce9c0b3fa74742eab138df419.tar
patches-d692228e8b47d40ce9c0b3fa74742eab138df419.tar.gz
gnu: Add ghc-split.
* gnu/packages/haskell.scm (ghc-split): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index bcc529b871..e930907fbd 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -691,4 +691,29 @@ optimized for performance critical use, both in terms of large data quantities
and high speed.")
(license bsd-3)))
+(define-public ghc-split
+ (package
+ (name "ghc-split")
+ (version "0.2.2")
+ (outputs '("out" "doc"))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/split/split-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0xa3j0gwr6k5vizxybnzk5fgb3pppgspi6mysnp2gwjp2dbrxkzr"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "http://hackage.haskell.org/package/split")
+ (synopsis
+ "Combinator library for splitting lists")
+ (description "A collection of various methods for splitting lists into
+parts, akin to the 'split' function found in several mainstream languages.")
+ (license bsd-3)))
+
;;; haskell.scm ends here