summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-30 22:22:30 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:47:48 -0500
commit064a967ba0480d35d706f96e8aa5bb86f0947b4d (patch)
treed6ffb0b137283662a313a7bdcd39c5ee0795baaa /gnu/packages/haskell.scm
parent477246878b766edb30a780190b2cead0c4b29156 (diff)
downloadpatches-064a967ba0480d35d706f96e8aa5bb86f0947b4d.tar
patches-064a967ba0480d35d706f96e8aa5bb86f0947b4d.tar.gz
gnu: Use GHC 8.6.5 as the main Haskell compiler.
* gnu/package/haskell.scm (ghc-8): Change to 'ghc-8.6'. * guix/import/hackage.scm (ghc-standard-libraries): Add 'ghc-heap' and 'libiserv'.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d86daa52c5..8db650e6ae 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -604,7 +604,7 @@ interactive environment for the functional language Haskell.")
(file-pattern ".*\\.conf\\.d$")
(file-type 'directory))))))
-(define-public ghc-8 ghc-8.4)
+(define-public ghc-8 ghc-8.6)
(define-public ghc ghc-8)