summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2018-03-21 03:45:04 +0000
committerLudovic Courtès <ludo@gnu.org>2018-03-31 19:27:40 +0200
commitd5c34f9b18087ee462512eed21e6d4a332f2235a (patch)
tree9fda99d7857dfe953f23606f45707c1b095885df /gnu/packages/haskell.scm
parent8434594d6d76c27bccf61b6c6d91d11e9869c0b1 (diff)
downloadpatches-d5c34f9b18087ee462512eed21e6d4a332f2235a.tar
patches-d5c34f9b18087ee462512eed21e6d4a332f2235a.tar.gz
gnu: Add ghc-unliftio-core.
* gnu/packages/haskell.scm (ghc-unliftio-core): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a5c86b50ce..7723eaa5ce 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9299,4 +9299,26 @@ ghc-aeson.")
functions for the ghc-persistent package.")
(license license:expat)))
+(define-public ghc-unliftio-core
+ (package
+ (name "ghc-unliftio-core")
+ (version "0.1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "unliftio-core-" version "/"
+ "unliftio-core-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1193fplsjm1lcr05xwvkj1rsyzx74i755f6kw3ikmxbsv0bv0l3m"))))
+ (build-system haskell-build-system)
+ (home-page
+ "https://github.com/fpco/unliftio/tree/master/unliftio-core#readme")
+ (synopsis "The MonadUnliftIO typeclass for unlifting monads to IO")
+ (description "This Haskell package provides the core @code{MonadUnliftIO}
+typeclass, instances for base and transformers, and basic utility
+functions.")
+ (license license:expat)))
+
;;; haskell.scm ends here