summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:49 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:17 -0700
commitb999b0092ec3a338a79474b804698f735e175883 (patch)
treeb86678fdb7d5e93de177859d38059b9bd966557a /gnu/packages/haskell.scm
parent6eda2635863d087a4cdacaea76ea5cadb8a2327c (diff)
downloadpatches-b999b0092ec3a338a79474b804698f735e175883.tar
patches-b999b0092ec3a338a79474b804698f735e175883.tar.gz
gnu: Add ghc-uuid-types.
* gnu/packages/haskell.scm (ghc-uuid-types): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e3801d20b3..21c6321d27 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9778,4 +9778,34 @@ getting a list of all the network interfaces and their respective
IPv4, IPv6 and MAC addresses.")
(license license:bsd-3)))
+(define-public ghc-uuid-types
+ (package
+ (name "ghc-uuid-types")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "uuid-types-" version "/"
+ "uuid-types-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1zdka5jnm1h6k36w3nr647yf3b5lqb336g3fkprhd6san9x52xlj"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-hashable" ,ghc-hashable)
+ ("ghc-random" ,ghc-random)
+ ("ghc-text" ,ghc-text)))
+ (native-inputs `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+ (home-page "https://github.com/hvr/uuid")
+ (synopsis "Haskell type definitions for UUIDs")
+ (description "This Haskell library contains type definitions for
+@dfn{Universally Unique Identifiers} or
+@uref{http://en.wikipedia.org/wiki/UUID, UUIDs}, and basic conversion
+functions.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here