summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:43 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:16 -0700
commit83c79ea0f8d64c5df68495ca31f4217b12dce312 (patch)
tree15737dab6840a51c28e254a4b3af0088d12e62d6 /gnu/packages/haskell.scm
parente2f6116e782aa705161095e0ae792d395dadaea3 (diff)
downloadpatches-83c79ea0f8d64c5df68495ca31f4217b12dce312.tar
patches-83c79ea0f8d64c5df68495ca31f4217b12dce312.tar.gz
gnu: Add ghc-crypto-api-tests.
* gnu/packages/haskell.scm (ghc-crypto-api-tests): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index ad86fc1ce8..675632b581 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9620,4 +9620,32 @@ Any concepts or functions of general use to more than one cryptographic
algorithm (ex: padding) is within scope of this package.")
(license license:bsd-3)))
+(define-public ghc-crypto-api-tests
+ (package
+ (name "ghc-crypto-api-tests")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "crypto-api-tests-" version "/"
+ "crypto-api-tests-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0w3j43jdrlj28jryp18hc6q84nkl2yf4vs1hhgrsk7gb9kfyqjpl"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
+ ("ghc-crypto-api" ,ghc-crypto-api)
+ ("ghc-cereal" ,ghc-cereal)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "https://github.com/TomMD/crypto-api-tests")
+ (synopsis "Test framework and KATs for cryptographic operations for Haskell")
+ (description "This Haskell package provides a test framework for hash and
+cipher operations using the crypto-api interface. Known answer tests (KATs)
+for common cryptographic algorithms are included.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here