summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-13 18:40:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-13 18:40:55 +0100
commit587d175266680d3a2300c429666e322bf85157f6 (patch)
tree9e049348444324fc8bfebe681f81bb035f3e9b04 /gnu/packages/haskell.scm
parentf24eba89f49ac3062ea4f43c4dfd342f76d3036a (diff)
downloadpatches-587d175266680d3a2300c429666e322bf85157f6.tar
patches-587d175266680d3a2300c429666e322bf85157f6.tar.gz
gnu: ghc-tls: Move to (gnu packages tls).
* gnu/packages/haskell.scm (ghc-tls): Move from here... * gnu/packages/tls.scm (ghc-tls): ...to here. * gnu/packages/haskell-web.scm: Use (gnu packages tls).
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm44
1 files changed, 1 insertions, 43 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 89aa62aeaf..802d387693 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -50,6 +50,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages sdl)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (guix build-system gnu)
@@ -5136,49 +5137,6 @@ different type of byte array abstraction, raw memory IO operations (memory
set, memory copy, ..) and more")
(license license:bsd-3)))
-(define-public ghc-tls
- (package
- (name "ghc-tls")
- (version "1.3.8")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://hackage.haskell.org/package/"
- "tls/tls-" version ".tar.gz"))
- (sha256
- (base32
- "1rdidf18i781c0vdvy9yn79yh08hmcacf6fp3sgghyiy3h0wyh5l"))))
- (build-system haskell-build-system)
- (inputs
- `(("ghc-mtl" ,ghc-mtl)
- ("ghc-cereal" ,ghc-cereal)
- ("ghc-data-default-class" ,ghc-data-default-class)
- ("ghc-memory" ,ghc-memory)
- ("ghc-cryptonite" ,ghc-cryptonite)
- ("ghc-asn1-types" ,ghc-asn1-types)
- ("ghc-asn1-encoding" ,ghc-asn1-encoding)
- ("ghc-x509" ,ghc-x509)
- ("ghc-x509-store" ,ghc-x509-store)
- ("ghc-x509-validation" ,ghc-x509-validation)
- ("ghc-async" ,ghc-async)
- ("ghc-network" ,ghc-network)
- ("ghc-hourglass" ,ghc-hourglass)))
- (native-inputs
- `(("ghc-tasty" ,ghc-tasty)
- ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
- ("ghc-quickcheck" ,ghc-quickcheck)))
- (home-page "https://github.com/vincenthz/hs-tls")
- (synopsis
- "TLS/SSL protocol native implementation (Server and Client)")
- (description
- "Native Haskell TLS and SSL protocol implementation for server and client.
-This provides a high-level implementation of a sensitive security protocol,
-eliminating a common set of security issues through the use of the advanced
-type system, high level constructions and common Haskell features. Currently
-implement the SSL3.0, TLS1.0, TLS1.1 and TLS1.2 protocol, and support RSA and
-Ephemeral (Elliptic curve and regular) Diffie Hellman key exchanges, and many
-extensions.")
- (license license:bsd-3)))
-
(define-public ghc-socks
(package
(name "ghc-socks")