summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorMekeor Melire <mekeor.melire@gmail.com>2017-01-23 10:45:52 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-23 11:01:17 +0100
commitc7bdb4139df22fbee40fb8dd717b96112110d5a7 (patch)
treea9e38f4c5cd50dae484568466cef44eee3705ec9 /gnu/packages/haskell.scm
parenta3dbea473a17bc0966d07c15b2c81ee6978e82a1 (diff)
downloadpatches-c7bdb4139df22fbee40fb8dd717b96112110d5a7.tar
patches-c7bdb4139df22fbee40fb8dd717b96112110d5a7.tar.gz
gnu: Add ghc-setlocale.
* gnu/packages/haskell.scm (ghc-setlocale): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index f28009f176..56b0090ee0 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1607,6 +1607,25 @@ UTF8 without truncation.")
environment variables.")
(license license:expat)))
+(define-public ghc-setlocale
+ (package
+ (name "ghc-setlocale")
+ (version "1.0.0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/setlocale-"
+ version "/setlocale-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1sd73zgpijr9xjdj5p562cmlcxmx5iff5k8xh9b6rpcgrgnnlf9j"))))
+ (build-system haskell-build-system)
+ (home-page "https://hackage.haskell.org/package/setlocale")
+ (synopsis "Haskell bindings to setlocale")
+ (description "This package provides Haskell bindings to the
+@code{setlocale} C function.")
+ (license license:bsd-3)))
+
(define-public ghc-x11
(package
(name "ghc-x11")