summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-10-04 15:12:15 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-06 14:18:25 +0200
commite9ef2c51d53ebbfdceff55587bf60f7763571df0 (patch)
tree1538f7b4dcca4ecdf4e52be4d8abf4f34ed8fca9 /gnu/packages/haskell.scm
parent1aa45bbf6fd11b474a9c364a2604df55ca9dc670 (diff)
downloadpatches-e9ef2c51d53ebbfdceff55587bf60f7763571df0.tar
patches-e9ef2c51d53ebbfdceff55587bf60f7763571df0.tar.gz
gnu: Add ghc-xml-types.
* gnu/packages/haskell.scm (ghc-xml-types): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 4a0c3347cc..bdd8141f6a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6407,6 +6407,26 @@ dependencies. The basic idea is that this package should only depend on
@code{haskell-platform} packages and @code{conduit}.")
(license license:expat)))
+(define-public ghc-xml-types
+ (package
+ (name "ghc-xml-types")
+ (version "0.3.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/xml-types/"
+ "xml-types-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1jgqxsa9p2q3h6nymbfmvhldqrqlwrhrzmwadlyc0li50x0d8dwr"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-text" ,ghc-text)))
+ (home-page "https://john-millikin.com/software/haskell-xml/")
+ (synopsis "Basic types for representing XML")
+ (description "This package provides basic types for representing XML
+documents.")
+ (license license:expat)))
+
(define-public ghc-union-find
(package
(name "ghc-union-find")