summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:10:17 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:10:00 -0400
commit58c85b1f8263a26e36f541e626ac7b30668bf1d2 (patch)
tree8f2bb5b0386425831d534243d9e32338ddab13e1 /gnu/packages/haskell.scm
parentc92d944c1e731ca5576c2acd90f04c2a708cf304 (diff)
downloadpatches-58c85b1f8263a26e36f541e626ac7b30668bf1d2.tar
patches-58c85b1f8263a26e36f541e626ac7b30668bf1d2.tar.gz
gnu: Add ghc-options.
* gnu/packages/haskell.scm (ghc-options): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index ea51e02620..b497380008 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7328,4 +7328,29 @@ testing strategies.")
(description "More complex tests for @code{chell}.")
(license license:expat)))
+(define-public ghc-options
+ (package
+ (name "ghc-options")
+ (version "1.2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/options/options-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0qjs0v1ny52w51n5582d4z8wy9h6n0zw1xb5dh686ff5wadflgi8"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-monads-tf" ,ghc-monads-tf)
+ ("ghc-chell" ,ghc-chell)
+ ("ghc-chell-quickcheck" ,ghc-chell-quickcheck)))
+ (home-page "https://john-millikin.com/software/haskell-options/")
+ (synopsis "Powerful and easy-to-use command-line option parser")
+ (description
+ "The @code{options} package lets library and application developers
+easily work with command-line options.")
+ (license license:expat)))
+
;;; haskell.scm ends here