summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:09:58 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:55 -0400
commit1d9db656c9498510e6b96d36b52838231dbd034e (patch)
tree5788bbc25b8806e84ab389fadb50cc8924782441 /gnu/packages/haskell.scm
parent41167bd2553b5fc3094cc91a5580fb847c7f5f86 (diff)
downloadpatches-1d9db656c9498510e6b96d36b52838231dbd034e.tar
patches-1d9db656c9498510e6b96d36b52838231dbd034e.tar.gz
gnu: Add ghc-bytestring.
* gnu/packages/haskell.scm (ghc-bytestring): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d8c849e4ee..13c5defcdd 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6850,4 +6850,41 @@ Polymorphism', by Mark P Jones. This package is almost a compatible replacement
the @code{mtl-tf} package.")
(license license:bsd-3)))
+(define-public ghc-bytestring
+ (package
+ (name "ghc-bytestring")
+ (version "0.10.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/bytestring/bytestring-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "16zwb1p83z7vc5wlhvknpy80b5a2jxc5awx67rk52qnp9idmyq9d"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-random" ,ghc-random)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-byteorder" ,ghc-byteorder)
+ ("ghc-dlist" ,ghc-dlist)
+ ("ghc-mtl" ,ghc-mtl)))
+ (arguments
+ `(#:tests? #f)) ; Test number two becomes non-responsive for 20+ minutes
+ (home-page "https://github.com/haskell/bytestring")
+ (synopsis "Fast, compact, strict and lazy byte strings with a list interface")
+ (description
+ "An efficient compact, immutable byte string type (both strict and lazy)
+suitable for binary or 8-bit character data. The 'ByteString' type represents
+sequences of bytes or 8-bit characters. It is suitable for high performance use,
+both in terms of large data quantities, or high speed requirements. The 'ByteString'
+functions follow the same style as ordinary lists, so it is easy to convert code
+from using 'String' to 'ByteString'.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here