summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2018-03-21 03:45:07 +0000
committerLudovic Courtès <ludo@gnu.org>2018-03-31 19:27:45 +0200
commite85c58edf9400b7f017608694a017ce2aeaae726 (patch)
treea0c13b3127a221e46f34dcd37985c35a82f50f3f /gnu/packages/haskell.scm
parent82e0b0e23f180494cfa61084e912b07cca60743f (diff)
downloadpatches-e85c58edf9400b7f017608694a017ce2aeaae726.tar
patches-e85c58edf9400b7f017608694a017ce2aeaae726.tar.gz
gnu: Add ghc-unliftio.
* gnu/packages/haskell.scm (ghc-unliftio): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 7cf152d1bf..7c557bbf54 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9371,4 +9371,33 @@ generated lenses are fully compatible with ones generated by lens (and can be
used both from lens and microlens).")
(license license:bsd-3)))
+(define-public ghc-unliftio
+ (package
+ (name "ghc-unliftio")
+ (version "0.2.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/unliftio/unliftio-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0vpncmwaq5zb6bziqfns4qdgxmq8ky0rlxna2yngxp170s5zxx9z"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ; FIXME: hspec-discover not in PATH
+ (inputs
+ `(("ghc-async" ,ghc-async)
+ ("ghc-stm" ,ghc-stm)
+ ("ghc-unliftio-core" ,ghc-unliftio-core)))
+ (native-inputs `(("ghc-hspec" ,ghc-hspec)))
+ (home-page "https://github.com/fpco/unliftio")
+ (synopsis "Provides MonadUnliftIO typecplass for unlifting monads to
+IO (batteries included)")
+ (description "This Haskell package provides the core @code{MonadUnliftIO}
+typeclass, a number of common instances, and a collection of common functions
+working with it.")
+ (license license:expat)))
+
;;; haskell.scm ends here