summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2018-03-21 03:44:54 +0000
committerLudovic Courtès <ludo@gnu.org>2018-03-31 19:27:18 +0200
commitd96a1bfe2bb029ac5cac4bcc07dc06a58ee36699 (patch)
treeef7212294a0751ccfb3d6a2ab93019abf6fc08d3 /gnu/packages/haskell.scm
parentaebe9d2556b368b931a95f4dff93d18fc13ce752 (diff)
downloadpatches-d96a1bfe2bb029ac5cac4bcc07dc06a58ee36699.tar
patches-d96a1bfe2bb029ac5cac4bcc07dc06a58ee36699.tar.gz
gnu: Add ghc-resource-pool.
* gnu/packages/haskell.scm (ghc-resource-pool): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 511d7b9932..d5052788aa 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9003,4 +9003,30 @@ Haskell")
a memory chunk that will be auto-scrubbed after it run out of scope.")
(license license:bsd-3)))
+(define-public ghc-resource-pool
+ (package
+ (name "ghc-resource-pool")
+ (version "0.2.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "resource-pool-" version "/"
+ "resource-pool-" version ".tar.gz"))
+ (sha256
+ (base32
+ "04mw8b9djb14zp4rdi6h7mc3zizh597ffiinfbr4m0m8psifw9w6"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-hashable" ,ghc-hashable)
+ ("ghc-monad-control" ,ghc-monad-control)
+ ("ghc-transformers-base" ,ghc-transformers-base)
+ ("ghc-stm" ,ghc-stm)
+ ("ghc-vector" ,ghc-vector)))
+ (home-page "https://github.com/bos/pool")
+ (synopsis "Striped resource pooling implementation in Haskell")
+ (description "This Haskell package provides striped pooling abstraction
+for managing flexibly-sized collections of resources such as database
+connections.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here