summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-06-20 07:55:34 +0200
committerTimothy Sample <samplet@ngyro.com>2019-07-19 23:09:48 -0400
commitf26f2e757ff206a24bc2a0b49f9bb1c292a0971a (patch)
treea0f9f858c2292d9d60a969ef3a16fcdeb786279d /gnu/packages/haskell.scm
parent3d33c93cef67d88bdc9409959f3c1f3857af09cf (diff)
downloadpatches-f26f2e757ff206a24bc2a0b49f9bb1c292a0971a.tar
patches-f26f2e757ff206a24bc2a0b49f9bb1c292a0971a.tar.gz
gnu: Add ghc-validity.
* gnu/packages/haskell.scm (ghc-validity): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a30b4376eb..19cd39e690 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11563,6 +11563,32 @@ stand for certain ASCII character sequences, i.e. → instead of @code{->},
∀ instead of @code{forall} and many others.")
(license license:bsd-3)))
+(define-public ghc-validity
+ (package
+ (name "ghc-validity")
+ (version "0.7.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/validity/validity-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0xribw98amafihw87ddajk6vlirp7w9b26lrnjgq7jfm4710j95f"))))
+ (build-system haskell-build-system)
+ (native-inputs `(("ghc-hspec" ,ghc-hspec)
+ ("hspec-discover" ,hspec-discover)))
+ (home-page
+ "https://github.com/NorfairKing/validity")
+ (synopsis "Validity typeclass")
+ (description
+ "Values of custom types usually have invariants imposed upon them. This
+package provides the @code{Validity} type class, which makes these invariants
+explicit by providing a function to check whether the invariants hold.")
+ (license license:expat)))
+
(define-public ghc-stylish-haskell
(package
(name "ghc-stylish-haskell")