summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:36:24 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commite24e053eda8784d2112b0f19f1e793b393d6a8c0 (patch)
tree088bb09993e1d23fd0f771fd7fd5bece2f4bbf8e /gnu/packages/haskell.scm
parent4dc2deb920079a893611b107244c4223e191be23 (diff)
downloadpatches-e24e053eda8784d2112b0f19f1e793b393d6a8c0.tar
patches-e24e053eda8784d2112b0f19f1e793b393d6a8c0.tar.gz
gnu: Add ghc-x509.
* gnu/packages/haskell.scm (ghc-x509): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index f805390a62..13942bb8b3 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5932,6 +5932,36 @@ different type of byte array abstraction, raw memory IO operations (memory
set, memory copy, ..) and more")
(license bsd-3)))
+(define-public ghc-x509
+ (package
+ (name "ghc-x509")
+ (version "1.6.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "x509/x509-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1pmsby29abn485fvnymsgipvb3p1ch9c591xj5ncszkf0ivjiiin"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-memory" ,ghc-memory)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-hourglass" ,ghc-hourglass)
+ ("ghc-pem" ,ghc-pem)
+ ("ghc-asn1-types" ,ghc-asn1-types)
+ ("ghc-asn1-encoding" ,ghc-asn1-encoding)
+ ("ghc-asn1-parse" ,ghc-asn1-parse)
+ ("ghc-cryptonite" ,ghc-cryptonite)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+ (home-page "http://github.com/vincenthz/hs-certificate")
+ (synopsis "X509 reader and writer")
+ (description
+ "This library provides functions to read and write X509 certificates.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")