summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-06-21 03:44:27 +0200
committerTimothy Sample <samplet@ngyro.com>2019-07-19 23:09:49 -0400
commita60056b5d309c76c0d88a962f106a158c1b38914 (patch)
tree36c6624b0be313dcc5cd095f3f44f4199ad2b444 /gnu/packages/haskell.scm
parentca20ee07b2ef05f37fc870c29439b3c980669ac4 (diff)
downloadpatches-a60056b5d309c76c0d88a962f106a158c1b38914.tar
patches-a60056b5d309c76c0d88a962f106a158c1b38914.tar.gz
gnu: Add ghc-descriptive.
* gnu/packages/haskell.scm (ghc-descriptive): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2aaa0585dd..fe860fb81f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11727,6 +11727,38 @@ recursive scanning and copying of directories, working with temporary
files/directories, and more.")
(license license:bsd-3)))
+(define-public ghc-descriptive
+ (package
+ (name "ghc-descriptive")
+ (version "0.9.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/descriptive/descriptive-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0y5693zm2kvqjilybbmrcv1g6n6x2p6zjgi0k0axjw1sdhh1g237"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-bifunctors" ,ghc-bifunctors)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-vector" ,ghc-vector)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-hspec" ,ghc-hspec)))
+ (home-page
+ "https://github.com/chrisdone/descriptive")
+ (synopsis
+ "Self-describing consumers/parsers: forms, cmd-line args, JSON, etc.")
+ (description
+ "This package provides datatypes and functions for creating consumers
+and parsers with useful semantics.")
+ (license license:bsd-3)))
+
(define-public ghc-stylish-haskell
(package
(name "ghc-stylish-haskell")