summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:39:31 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commit85538709f12ebfc307377477b062ed4282d5ae9d (patch)
treea66cf4889a3d7b610c5e156ab58f3d88fe4fef89 /gnu/packages/haskell.scm
parentac2607a0cef65e8c0faa5205e734244e1f45bb4a (diff)
downloadpatches-85538709f12ebfc307377477b062ed4282d5ae9d.tar
patches-85538709f12ebfc307377477b062ed4282d5ae9d.tar.gz
gnu: Add ghc-pandoc.
* gnu/packages/haskell.scm (ghc-pandoc): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm73
1 files changed, 73 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0bd822f010..c230c8737f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6173,6 +6173,79 @@ connection and TLS libraries. It is intended for use by higher-level
libraries, such as http-conduit.")
(license expat)))
+(define-public ghc-pandoc
+ (package
+ (name "ghc-pandoc")
+ (version "1.15.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/pandoc/pandoc-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0nfzwsdvrvg9zypgyqk0246p10yzlpqsqnkds8yraqybbvkb1g30"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-syb" ,ghc-syb)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-parsec" ,ghc-parsec)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-text" ,ghc-text)
+ ("ghc-zip-archive" ,ghc-zip-archive)
+ ("ghc-http" ,ghc-http)
+ ("ghc-texmath" ,ghc-texmath)
+ ("ghc-xml" ,ghc-xml)
+ ("ghc-random" ,ghc-random)
+ ("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
+ ("ghc-pandoc-types" ,ghc-pandoc-types)
+ ("ghc-aeson" ,ghc-aeson)
+ ("ghc-tagsoup" ,ghc-tagsoup)
+ ("ghc-base64-bytestring" ,ghc-base64-bytestring)
+ ("ghc-zlib" ,ghc-zlib)
+ ("ghc-highlighting-kate" ,ghc-highlighting-kate)
+ ("ghc-data-default" ,ghc-data-default)
+ ("ghc-temporary" ,ghc-temporary)
+ ("ghc-blaze-html" ,ghc-blaze-html)
+ ("ghc-blaze-markup" ,ghc-blaze-markup)
+ ("ghc-yaml" ,ghc-yaml)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-hslua" ,ghc-hslua)
+ ("ghc-sha" ,ghc-sha)
+ ("ghc-haddock-library" ,ghc-haddock-library)
+ ("ghc-old-time" ,ghc-old-time)
+ ("ghc-deepseq-generics" ,ghc-deepseq-generics)
+ ("ghc-juicypixels" ,ghc-juicypixels)
+ ("ghc-filemanip" ,ghc-filemanip)
+ ("ghc-cmark" ,ghc-cmark)
+ ("ghc-network-uri" ,ghc-network-uri)
+ ("ghc-network" ,ghc-network)
+ ("ghc-http-client" ,ghc-http-client)
+ ("ghc-http-client-tls" ,ghc-http-client-tls)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-diff" ,ghc-diff)
+ ("ghc-ansi-terminal" ,ghc-ansi-terminal)
+ ("ghc-executable-path" ,ghc-executable-path)))
+ (native-inputs
+ `(("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hunit" ,ghc-hunit)))
+ (home-page "http://pandoc.org")
+ (synopsis "Conversion between markup formats")
+ (description
+ "Pandoc is a Haskell library for converting from one markup format to
+another, and a command-line tool that uses this library. It can read and
+write Markdown and (subsets of) other formats, such as HTML, reStructuredText,
+LaTeX, DocBook, and many more.
+
+Pandoc extends standard Markdown syntax with footnotes, embedded LaTeX,
+definition lists, tables, and other features. A compatibility mode is
+provided for those who need a drop-in replacement for Markdown.pl.")
+ (license gpl2+)))
+
(define-public idris
(package
(name "idris")