summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:37:11 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commit1c649948c9bcc7271018f64e44fed664436fe2fe (patch)
tree21de6a9603333aaf50b430318f8408b6e7fe1764 /gnu/packages/haskell.scm
parent282f11420b0c90e60afdfe63ea4c6cd89d4c36ba (diff)
downloadpatches-1c649948c9bcc7271018f64e44fed664436fe2fe.tar
patches-1c649948c9bcc7271018f64e44fed664436fe2fe.tar.gz
gnu: Add ghc-x509-validation.
* gnu/packages/haskell.scm (ghc-x509-validation): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 5cdf0c963e..d780d3d465 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5989,6 +5989,38 @@ set, memory copy, ..) and more")
collections, certificates, revocation lists, and exception lists.")
(license bsd-3)))
+(define-public ghc-x509-validation
+ (package
+ (name "ghc-x509-validation")
+ (version "1.6.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "x509-validation/x509-validation-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1qr1v561hdlhjgqjv9pj9mbk0q1xf2mr1j67ghy93nlxxyzd7dw0"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-memory" ,ghc-memory)
+ ("ghc-byteable" ,ghc-byteable)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-hourglass" ,ghc-hourglass)
+ ("ghc-data-default-class" ,ghc-data-default-class)
+ ("ghc-pem" ,ghc-pem)
+ ("ghc-asn1-types" ,ghc-asn1-types)
+ ("ghc-asn1-encoding" ,ghc-asn1-encoding)
+ ("ghc-x509" ,ghc-x509)
+ ("ghc-x509-store" ,ghc-x509-store)
+ ("ghc-cryptonite" ,ghc-cryptonite)))
+ (home-page "http://github.com/vincenthz/hs-certificate")
+ (synopsis "X.509 certificate and revocation list validation")
+ (description
+ "This package provides functions for X.509 certificate and revocation
+list validation.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")