summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:28:41 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commit1300634bf15f6e1831eb898c016c2e8f61d98732 (patch)
treefe7b4e959347d8145d7db89354647392cf9da865 /gnu/packages/haskell.scm
parentcb31771f8443efb09a47605a70fc8ac999aeb998 (diff)
downloadpatches-1300634bf15f6e1831eb898c016c2e8f61d98732.tar
patches-1300634bf15f6e1831eb898c016c2e8f61d98732.tar.gz
gnu: Add ghc-hspec-contrib.
* gnu/packages/haskell.scm (ghc-hspec-contrib): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 7d1426c2cc..65cc954d5d 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3435,6 +3435,30 @@ responses coming back.")
Haskell, inspired by the Ruby library RSpec.")
(license expat)))
+(define-public ghc-hspec-contrib
+ (package
+ (name "ghc-hspec-contrib")
+ (version "0.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "hspec-contrib/hspec-contrib-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "006syw8xagfhsx06ws9ywig1qx5lk4cgl7sq6pbid1s64c72mxn4"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-hspec-core" ,ghc-hspec-core)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "http://hspec.github.io/")
+ (synopsis "Contributed functionality for Hspec")
+ (description
+ "This package provides contributed Hspec extensions.")
+ (license expat)))
+
(define-public ghc-hspec-expectations
(package
(name "ghc-hspec-expectations")