summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-13 07:00:31 -0800
committerChristopher Baines <mail@cbaines.net>2020-05-08 09:53:22 +0100
commitd7ad08239be312e48c18487bf4b6cc173970de6d (patch)
treecffdc05f26419f446bf298b9371821556351f4dc /gnu/packages/haskell-xyz.scm
parent503447ad4e06fbd64374563abbae2328568c3eda (diff)
downloadpatches-d7ad08239be312e48c18487bf4b6cc173970de6d.tar
patches-d7ad08239be312e48c18487bf4b6cc173970de6d.tar.gz
gnu: Add ghc-utf8-light.
* gnu/packages/haskell-xyz.scm (ghc-utf8-light): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index c9119efd69..1ff6f30141 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -12671,6 +12671,31 @@ a style ready for qualification, that is, you should import them by
parser that uses ByteStrings for parsing and representing the URI data.")
(license license:bsd-3)))
+(define-public ghc-utf8-light
+ (package
+ (name "ghc-utf8-light")
+ (version "0.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/utf8-light/utf8-light-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0rwyc5z331yfnm4hpx0sph6i1zvkd1z10vvglhnp0vc9wy644k0q"))))
+ (build-system haskell-build-system)
+ (home-page
+ "http://hackage.haskell.org/package/utf8-light")
+ (synopsis "Lightweight unicode support for Haskell")
+ (description
+ "This package profides a class for encoding and decoding UTF8 strings
+with instances for several common types. It also includes several functions
+for working with UTF8. It aims to be lightweight, depending only on Base and
+including only one module.")
+ (license license:bsd-3)))
+
(define-public ghc-utf8-string
(package
(name "ghc-utf8-string")