summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-13 07:41:40 -0800
committerChristopher Baines <mail@cbaines.net>2020-05-08 09:53:25 +0100
commit25a221a80b29900538438926123ba253a6b0341c (patch)
tree61be64efb79ea3a49d7baca521159f935a5595ad /gnu/packages/haskell-xyz.scm
parent8a6e745df12e21705620b59e7adb1ec309366a4c (diff)
downloadpatches-25a221a80b29900538438926123ba253a6b0341c.tar
patches-25a221a80b29900538438926123ba253a6b0341c.tar.gz
gnu: Add ghc-pattern-arrows.
* gnu/packages/haskell-xyz.scm (ghc-pattern-arrows): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index eef1765a71..3f9fd167d1 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8759,6 +8759,29 @@ of two versions of a source file. It provides a good balance between
performance, nice output for humans, and simplicity of implementation.")
(license license:bsd-3)))
+(define-public ghc-pattern-arrows
+ (package
+ (name "ghc-pattern-arrows")
+ (version "0.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/pattern-arrows/pattern-arrows-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "13q7bj19hd60rnjfc05wxlyck8llxy11z3mns8kxg197wxrdkhkg"))))
+ (build-system haskell-build-system)
+ (home-page
+ "https://blog.functorial.com/posts/2013-10-27-Pretty-Printing-Arrows.html")
+ (synopsis "Arrows for Pretty Printing")
+ (description
+ "A library for generating concise pretty printers based on precedence
+rules.")
+ (license license:expat)))
+
(define-public ghc-pcre-light
(package
(name "ghc-pcre-light")