summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-07-07 17:52:53 -0700
committerTimothy Sample <samplet@ngyro.com>2019-09-02 23:09:38 -0400
commit1307e4c73d25cd89996b0841c2f84a84acbdb573 (patch)
treedf7d079665408ff42e4f6975a770ebdf7c848f9f /gnu/packages/haskell-xyz.scm
parentad80074ab0e04c4f955b195ee017f25eec0efc1c (diff)
downloadpatches-1307e4c73d25cd89996b0841c2f84a84acbdb573.tar
patches-1307e4c73d25cd89996b0841c2f84a84acbdb573.tar.gz
gnu: Add ghc-listlike.
* gnu/packages/haskell-xyz.scm (ghc-listlike): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 72b9c2518c..fd4d464cfc 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -5810,6 +5810,41 @@ Kaseorg.")
vector spaces.")
(license license:bsd-3)))
+(define-public ghc-listlike
+ (package
+ (name "ghc-listlike")
+ (version "4.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://hackage.haskell.org/package/ListLike/ListLike-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0m65x8yaq7q50gznln8mga2wrc8cvjx6gw9rim8s7xqcrx6y5zjh"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-vector" ,ghc-vector)
+ ("ghc-dlist" ,ghc-dlist)
+ ("ghc-fmlist" ,ghc-fmlist)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-random" ,ghc-random)
+ ("ghc-utf8-string" ,ghc-utf8-string)))
+ (home-page "https://github.com/JohnLato/listlike")
+ (synopsis "Generic support for list-like structures")
+ (description "The ListLike module provides a common interface to the
+various Haskell types that are list-like. Predefined interfaces include
+standard Haskell lists, Arrays, ByteStrings, and lazy ByteStrings.
+Custom types can easily be made ListLike instances as well.
+
+ListLike also provides for String-like types, such as String and
+ByteString, for types that support input and output, and for types that
+can handle infinite lists.")
+ (license license:bsd-3)))
+
(define-public ghc-logging-facade
(package
(name "ghc-logging-facade")