summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-07-07 17:30:41 -0700
committerTimothy Sample <samplet@ngyro.com>2019-09-02 23:09:37 -0400
commit6b652f5af3ddf9d8d894d1270441ab29354cca97 (patch)
tree6204866f171fa4705975817eddb386c129fe1d32 /gnu/packages/haskell-xyz.scm
parenta52f4c5740ea7ad7776cb399eef0eccabe85127c (diff)
downloadpatches-6b652f5af3ddf9d8d894d1270441ab29354cca97.tar
patches-6b652f5af3ddf9d8d894d1270441ab29354cca97.tar.gz
gnu: Add ghc-non-negative.
* gnu/packages/haskell-xyz.scm (ghc-non-negative): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 8d7614240e..2dbafe6770 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6736,6 +6736,33 @@ making this package a full replacement for the original newtype package,
and an alternative to newtype-th.")
(license license:bsd-3)))
+(define-public ghc-non-negative
+ (package
+ (name "ghc-non-negative")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://hackage.haskell.org/package/non-negative/non-negative-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0f01q916dzkl1i0v15qrw9cviycki5g3fgi6x8gs45iwbzssq52n"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-utility-ht" ,ghc-utility-ht)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "https://hackage.haskell.org/package/non-negative")
+ (synopsis "Non-negative numbers class")
+ (description "This library provides a class for non-negative numbers,
+a wrapper which can turn any ordered numeric type into a member of that
+class, and a lazy number type for non-negative numbers (a generalization
+of Peano numbers).")
+ (license license:gpl3+)))
+
(define-public ghc-objectname
(package
(name "ghc-objectname")