summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-11-14 01:10:31 -0800
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:51 -0500
commitff0f5786a4f857a3faf8836f61431a130ea9bb9b (patch)
tree347d8e104fe9af089729afa9e162159dc98632f1 /gnu/packages/haskell-xyz.scm
parent2ed8bd2d7df6235617e982b1fc01859c4dc657f6 (diff)
downloadpatches-ff0f5786a4f857a3faf8836f61431a130ea9bb9b.tar
patches-ff0f5786a4f857a3faf8836f61431a130ea9bb9b.tar.gz
gnu: Add ghc-timezone-olson.
* gnu/packages/haskell-xyz.scm (ghc-timezone-olson): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 762acc3efc..a05d998228 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -11133,6 +11133,35 @@ data types and functions for enhanced processing of timezones. For one way to
create timezone series, see the ghc-timezone-olson package.")
(license license:bsd-3)))
+(define-public ghc-timezone-olson
+ (package
+ (name "ghc-timezone-olson")
+ (version "0.1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "mirror://hackage/package/timezone-olson/timezone-olson-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "05abywx1nrcaz0nqzfy4zw62bc5qd7pdfnjvv4drxkwv084ha8rj"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-timezone-series" ,ghc-timezone-series)
+ ("ghc-extensible-exceptions" ,ghc-extensible-exceptions)))
+ (home-page "https://archives.haskell.org/projects.haskell.org/time-ng/")
+ (synopsis "Parser and renderer for binary Olson timezone files")
+ (description
+ "A parser and renderer for binary Olson timezone files whose format
+is specified by the tzfile(5) man page on Unix-like systems. For more
+information about this format, see
+@url{http://www.iana.org/time-zones/repository/tz-link.html}. Functions
+are provided for converting the parsed data into @code{TimeZoneSeries}
+objects from the timezone-series package.")
+ (license license:bsd-3)))
+
(define-public ghc-tldr
(package
(name "ghc-tldr")