summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-13 00:33:54 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:52 -0500
commitf3e18645e0e344178761ce28ca5c55ac25abc232 (patch)
treeebaaadd613f033182b45e35f9e7546ff57da7016 /gnu/packages/haskell-xyz.scm
parentf9cad2a0b9e11514520382b3cd87b144b46e3d1e (diff)
downloadpatches-f3e18645e0e344178761ce28ca5c55ac25abc232.tar
patches-f3e18645e0e344178761ce28ca5c55ac25abc232.tar.gz
gnu: Add ghc-groups.
* gnu/packages/haskell-xyz.scm (ghc-groups): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 9d160a2d6a..63ec19f88a 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -4379,6 +4379,25 @@ and edge labels with positional information, etc.
@end enumerate\n")
(license license:bsd-3)))
+(define-public ghc-groups
+ (package
+ (name "ghc-groups")
+ (version "0.4.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "groups/groups-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ggkygkyxw5ga4cza82bjvdraavl294k0h6b62d2px7z3nvqhifx"))))
+ (build-system haskell-build-system)
+ (home-page "https://hackage.haskell.org/package/groups")
+ (synopsis "Haskell 98 groups")
+ (description "This package provides Haskell 98 groups. A group is a
+monoid with invertibility.")
+ (license license:bsd-3)))
+
(define-public ghc-gtk2hs-buildtools
(package
(name "ghc-gtk2hs-buildtools")