summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-08 21:56:05 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:48 -0500
commit24cf2a8b1294dd2e2bd87b0ca54b5da5c7bac363 (patch)
treef8d5dcd025c80edfd2d700632b77728a626646d6 /gnu/packages/haskell-xyz.scm
parenta54dda095f5568545f1de0c53c01e4d39ae42f9b (diff)
downloadpatches-24cf2a8b1294dd2e2bd87b0ca54b5da5c7bac363.tar
patches-24cf2a8b1294dd2e2bd87b0ca54b5da5c7bac363.tar.gz
gnu: ghc-options: Fix Cabal dependency constraints.
* gnu/packages/haskell-xyz.scm (ghc-options): Add a phase that updates the Cabal file to allow for newer versions of 'chell'.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 052162b66d..4b092299be 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -7570,6 +7570,14 @@ DSLs, etc.")
(base32
"0qjs0v1ny52w51n5582d4z8wy9h6n0zw1xb5dh686ff5wadflgi8"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'update-constraints
+ (lambda _
+ (substitute* "options.cabal"
+ (("chell >= 0\\.4 && < 0\\.5") "chell >= 0.4 && < 0.6"))
+ #t)))))
(inputs
`(("ghc-monads-tf" ,ghc-monads-tf)
("ghc-chell" ,ghc-chell)