summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-03 08:39:29 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:46 -0500
commit4828e54eaa9f46e04f9e4d23e5f2c245c94e20a0 (patch)
tree75e037cf1470a315cd992086e9da7b0d7508b0b1 /gnu/packages/haskell-xyz.scm
parentff303e4ebf5cc31b1f00ec48a2f377673f67adad (diff)
downloadpatches-4828e54eaa9f46e04f9e4d23e5f2c245c94e20a0.tar
patches-4828e54eaa9f46e04f9e4d23e5f2c245c94e20a0.tar.gz
gnu: Add ghc-ipynb.
* gnu/packages/haskell-xyz.scm (ghc-ipynb): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 0d9339407e..b35452c60c 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -5738,6 +5738,38 @@ them on the longest match base. It is a kind of TRIE with one way branching
removed. Both IPv4 and IPv6 are supported.")
(license license:bsd-3)))
+(define-public ghc-ipynb
+ (package
+ (name "ghc-ipynb")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "ipynb/ipynb-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0daadhzil4q573mqb0rpvjzm0vpkzgzqcimw480qpvlh6rhppwj5"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-base64-bytestring" ,ghc-base64-bytestring)
+ ("ghc-aeson" ,ghc-aeson)
+ ("ghc-semigroups" ,ghc-semigroups)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-aeson-diff" ,ghc-aeson-diff)
+ ("ghc-microlens-aeson" ,ghc-microlens-aeson)
+ ("ghc-microlens" ,ghc-microlens)
+ ("ghc-vector" ,ghc-vector)))
+ (home-page "https://hackage.haskell.org/package/ipynb")
+ (synopsis "Data structure for working with Jupyter notebooks")
+ (description "This library defines a data structure for representing
+Jupyter notebooks, along with @code{ToJSON} and @code{FromJSON}
+instances for conversion to and from JSON .ipynb files.")
+ (license license:bsd-3)))
+
(define-public ghc-iwlib
(package
(name "ghc-iwlib")