summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 13:33:24 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:44 -0500
commit10707d572034e7389211cbe3df30dd92f93124f7 (patch)
tree6fbb56b956b2c9078a0eb6a0f1baa8ade6e85d9d /gnu/packages/haskell-xyz.scm
parent1e0db876d1fb37720f1a9697f9bda34a17ab6e84 (diff)
downloadpatches-10707d572034e7389211cbe3df30dd92f93124f7.tar
patches-10707d572034e7389211cbe3df30dd92f93124f7.tar.gz
gnu: ghc-haddock-library: Update to 1.7.0.
The new source tarball does not have bundled dependencies, so it does not need to be patched. * gnu/packages/haskell-xyz.scm (ghc-haddock-library): Update to 1.7.0. [source]: Remove 'patches', 'modules' and 'snippet'. [arguments]: Update the 'relax-test-suite-dependencies' phase to allow newer versions of 'hspec' and 'QuickCheck'; remove the 'add-examples-directory' phase. * gnu/packages/patches/ghc-haddock-library-unbundle.patch: Delete file. * gnu/local.mk: Remove it.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm23
1 files changed, 6 insertions, 17 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 37f56df89b..bd5b599ace 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -4328,7 +4328,7 @@ documentation-generation tool for Haskell libraries.")
(define-public ghc-haddock-library
(package
(name "ghc-haddock-library")
- (version "1.5.0.1")
+ (version "1.7.0")
(source
(origin
(method url-fetch)
@@ -4338,29 +4338,18 @@ documentation-generation tool for Haskell libraries.")
".tar.gz"))
(sha256
(base32
- "1cmbg8l5xrwpliclwy3l057raypjqy0hsg1h1743ahaj8gq10b7z"))
- (patches (search-patches
- "ghc-haddock-library-unbundle.patch"))
- (modules '((guix build utils)))
- (snippet '(begin
- (delete-file-recursively "vendor")
- #t))))
+ "04fhcjk0pvsaqvsgp2w06cv2qvshq1xs1bwc157q4lmkgr57khp7"))))
(build-system haskell-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
+ ;; Since there is no revised Cabal file upstream, we have to
+ ;; patch it manually.
(add-before 'configure 'relax-test-suite-dependencies
(lambda _
(substitute* "haddock-library.cabal"
- (("base-compat\\s*\\^>= 0\\.9\\.3") "base-compat")
- (("hspec\\s*\\^>= 2\\.4\\.4") "hspec"))))
- ;; The release tarball does not contain the "fixtures/examples"
- ;; directory, which is required for testing. In the upstream
- ;; repository, the directory exists and is populated. Here, we
- ;; create an empty directory to placate the tests.
- (add-before 'check 'add-examples-directory
- (lambda _
- (mkdir "fixtures/examples")
+ (("hspec\\s*>= 2.4.4 && < 2.6") "hspec")
+ (("QuickCheck\\s*\\^>= 2.11") "QuickCheck"))
#t)))))
(native-inputs
`(("ghc-base-compat" ,ghc-base-compat)