summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-15 11:22:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:11 +0200
commit57f25c7d9eb392c8332809fe175466c93922a3d4 (patch)
treeca939810528d85cf4fcaa9899f43dea6b343748c /gnu/packages/haskell-web.scm
parent545de2a28cb5e6f9c6cf0fcf045f867f5db5db51 (diff)
downloadpatches-57f25c7d9eb392c8332809fe175466c93922a3d4.tar
patches-57f25c7d9eb392c8332809fe175466c93922a3d4.tar.gz
gnu: Add ghc-httpd-shed.
* gnu/packages/haskell-web.scm (ghc-httpd-shed): New variable.
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 83de9614d0..6154aa2174 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -91,6 +91,30 @@ for screen-scraping.")
(description "HTTP cookie parsing and rendering library for Haskell.")
(license license:bsd-3)))
+(define-public ghc-httpd-shed
+ (package
+ (name "ghc-httpd-shed")
+ (version "0.4.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/httpd-shed/"
+ "httpd-shed-" version ".tar.gz"))
+ (sha256
+ (base32
+ "064jy1mqhnf1hvq6s04wlhmp916rd522x58djb9qixv13vc8gzxh"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-network-uri" ,ghc-network-uri)
+ ("ghc-network" ,ghc-network)))
+ (home-page "https://hackage.haskell.org/package/httpd-shed")
+ (synopsis "Simple web-server with an interact style API")
+ (description
+ "This web server promotes a function from @code{Request} to @code{IO
+Response} into a local web server. The user can decide how to interpret the
+requests, and the library is intended for implementing Ajax APIs.")
+ (license license:bsd-3)))
+
(define-public ghc-http-types
(package
(name "ghc-http-types")